「BSD小僧の日記」
2003/11版 その3



2003/11/21 (金)

1年と276日目

朝はやっぱり自転車だね。

今日は比較的気温が高くて良かった。


[View Log(0)] [Trackback]
Name: Comment:

見つかった

昨日紛失したカバンが見つかった。

遺失物をまとめてとり扱う所に集められているらしい。

ということで、引き取りにいく。

内容物すべて無事で本当に良かった。

ほぼ諦めていたので、ACアダプタの型番とか調べてたからなぁ。

回収してくれた人、本当にありがとう。


[View Log(0)] [Trackback]
Name: Comment:

もつ8

もつ8が開催された。

開始当初は二人でこぢんまりと始まったけど、最終的には四人参加。

かなり濃い話が大量に炸裂。大漁の話題もでた。

本日のキーワードは「チャレンジャー四谷」ですね。


[View Log(0)] [Trackback]
Name: Comment:

2003/11/22 (土)

1年と277日目

大江戸温泉物語なるアミューズメント施設に行く。

大騒ぎしてましたな。


[View Log(0)] [Trackback]
Name: Comment:

NetBSD/evbppc

sys/dev/pci以下のファイルにHPT371を動かすような修正を入れてwdを認識できるようにした。

--- ./sys/dev/pci/hptide.c.orig	2003-11-22 15:50:11.000000000 +0000
+++ ./sys/dev/pci/hptide.c	2003-11-22 15:54:59.000000000 +0000
@@ -54,6 +54,11 @@
 	  NULL,
 	  hpt_chip_map,
 	},
+	{ PCI_PRODUCT_TRIONES_HPT371,
+	  0,
+	  NULL,
+	  hpt_chip_map
+	},
 	{ PCI_PRODUCT_TRIONES_HPT372,
 	  0,
 	  NULL,
@@ -110,6 +115,8 @@
 	    sc->sc_wdcdev.sc_dev.dv_xname);
 	if (sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT374)
 		aprint_normal("HPT374 IDE Controller\n");
+	else if (sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT371)
+		aprint_normal("HPT371 IDE Controller\n");
 	else if (sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT372)
 		aprint_normal("HPT372 IDE Controller\n");
 	else if (sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT366) {
@@ -140,6 +147,7 @@
 		if ((sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT366 &&
 		    (revision == HPT370_REV || revision == HPT370A_REV ||
 		     revision == HPT372_REV)) ||
+		    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT371 ||
 		    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT372 ||
 		    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT374)
 			interface |= PCIIDE_INTERFACE_PCI(1);
@@ -168,6 +176,7 @@
 	} else {
 		sc->sc_wdcdev.nchannels = 2;
 		if (sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT374 ||
+		    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT371 ||
 		    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT372 ||
 		    (sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT366 &&
 		    revision == HPT372_REV))
@@ -217,6 +226,7 @@
 	if ((sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT366 &&
 	    (revision == HPT370_REV || revision == HPT370A_REV ||
 	     revision == HPT372_REV)) || 
+	    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT371 ||
 	    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT372 ||
 	    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT374) {
 		/*
@@ -230,6 +240,7 @@
 	/* set clocks, etc (mandatory on 372/4, optional otherwise) */
 	if ((sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT366 &&
 	     revision == HPT372_REV ) ||
+	    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT371 ||
 	    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT372 ||
 	    sc->sc_pp->ide_product == PCI_PRODUCT_TRIONES_HPT374)
 		pciide_pci_write(sc->sc_pc, sc->sc_tag, HPT_SC2,
@@ -278,6 +289,9 @@
 			case PCI_PRODUCT_TRIONES_HPT374:
 				after = hpt374_udma[drvp->UDMA_mode];
 				break;
+			case PCI_PRODUCT_TRIONES_HPT371:
+				after = hpt371_udma[drvp->UDMA_mode];
+				break;
 			case PCI_PRODUCT_TRIONES_HPT372:
 				after = hpt372_udma[drvp->UDMA_mode];
 				break;
@@ -312,6 +326,9 @@
 			case PCI_PRODUCT_TRIONES_HPT374:
 				after = hpt374_dma[drvp->DMA_mode];
 				break;
+			case PCI_PRODUCT_TRIONES_HPT371:
+				after = hpt371_dma[drvp->DMA_mode];
+				break;
 			case PCI_PRODUCT_TRIONES_HPT372:
 				after = hpt372_dma[drvp->DMA_mode];
 				break;
@@ -338,6 +355,9 @@
 			case PCI_PRODUCT_TRIONES_HPT374:
 				after = hpt374_pio[drvp->PIO_mode];
 				break;
+			case PCI_PRODUCT_TRIONES_HPT371:
+				after = hpt371_pio[drvp->PIO_mode];
+				break;
 			case PCI_PRODUCT_TRIONES_HPT372:
 				after = hpt372_pio[drvp->PIO_mode];
 				break;
--- ./sys/dev/pci/pcidevs.orig	2003-11-22 15:50:26.000000000 +0000
+++ ./sys/dev/pci/pcidevs	2003-11-22 15:56:55.000000000 +0000
@@ -2492,6 +2492,7 @@
 /* Triones Technologies products */
 /* The 366 and 370 controllers have the same product ID */
 product TRIONES HPT366		0x0004	HPT366/370 IDE Controller
+product TRIONES HPT371		0x0007	HPT371 IDE Controller
 product TRIONES HPT372		0x0005	HPT372 IDE Controller
 product TRIONES HPT302		0x0006	HPT302 IDE Controller
 product TRIONES HPT374		0x0008	HPT374 IDE Controller
--- ./sys/dev/pci/pcidevs.h.orig	2003-11-22 17:55:12.000000000 +0000
+++ ./sys/dev/pci/pcidevs.h	2003-11-22 16:20:44.000000000 +0000
@@ -2499,6 +2499,7 @@
 /* Triones Technologies products */
 /* The 366 and 370 controllers have the same product ID */
 #define	PCI_PRODUCT_TRIONES_HPT366	0x0004		/* HPT366/370 IDE Controller */
+#define	PCI_PRODUCT_TRIONES_HPT371	0x0007		/* HPT371 IDE Controller */
 #define	PCI_PRODUCT_TRIONES_HPT372	0x0005		/* HPT372 IDE Controller */
 #define	PCI_PRODUCT_TRIONES_HPT302	0x0006		/* HPT302 IDE Controller */
 #define	PCI_PRODUCT_TRIONES_HPT374	0x0008		/* HPT374 IDE Controller */
--- ./sys/dev/pci/pciide_hpt_reg.h.orig	2003-11-22 15:50:46.000000000 +0000
+++ ./sys/dev/pci/pciide_hpt_reg.h	2003-11-22 16:00:38.000000000 +0000
@@ -139,6 +139,14 @@
 	{0x16514e31, 0x164d4e31, 0x16494e31, 0x166d4e31, 0x16454e31,
 	 0x1a85f442};
 
+static const u_int32_t hpt371_pio[] __attribute__((__unused__)) =
+	{0x0ac1f48a, 0x0ac1f465, 0x0a81f454, 0x0a81f443, 0x0a81f442};
+static const u_int32_t hpt371_dma[] __attribute__((__unused__)) =
+	{0x228082ea, 0x22808254, 0x22808242};
+static const u_int32_t hpt371_udma[] __attribute__((__unused__)) =
+	{0x121882ea, 0x12148254, 0x120c8242, 0x128c8242, 0x12ac8242,
+	 0x12848242, 0x12808242};
+
 static const u_int32_t hpt372_pio[] __attribute__((__unused__)) =
 	{0x0d029d5e, 0x0d029d26, 0x0c829ca6, 0x0c829c84, 0x0c829c62};
 static const u_int32_t hpt372_dma[] __attribute__((__unused__)) =
--- ./sys/dev/pci/pcidevs_data.h.orig	2003-11-22 15:50:59.000000000 +0000
+++ ./sys/dev/pci/pcidevs_data.h	2003-11-22 15:57:32.000000000 +0000
@@ -9046,6 +9046,12 @@
 	    "HPT366/370 IDE Controller",
 	},
 	{
+	    PCI_VENDOR_TRIONES, PCI_PRODUCT_TRIONES_HPT371,
+	    0,
+	    "Triones Technologies",
+	    "HPT371 IDE Controller",
+	},
+	{
 	    PCI_VENDOR_TRIONES, PCI_PRODUCT_TRIONES_HPT372,
 	    0,
 	    "Triones Technologies",

で、wdを認識させてdisklabel書いてnewfsして、などとやる。以下はその記録。

で失敗してるし。あぁ、fstab書き間違えてら (/usrのとこ)。まぁ、きょうはここまで。

405GPr 1.2 ROM Monitor (5/25/02)
 --------------------- System Info ----------------------
 Processor         = 405GPr (New mode),   PVR: 50910951
 CPU speed         = 266 MHz
 PLB speed         = 133 MHz
 OPB speed         = 66 MHz
 EBC speed         = 66 MHz
 PCI Bus speed     = 33 MHz (Async)
 VCO speed         = 800 MHz
 Feedback Clock    = CPU
 Amount of SDRAM   = 64 MBytes 
 Internal PCI arbiter enabled
 --------------------------------------------------------
 --- Device Configuration ---
 Power-On Test Devices:
   000  Enabled   System Memory [RAM]
   002  Enabled   Ethernet      [ENET]
   003  Enabled   PCI Ethernet  [PCIENET]
 ----------------------------
 Boot Sources:
   001  Disabled  System FLASH  [FLASH]
   002  Enabled   Ethernet      [ENET]
                  LOCAL:  192.168.100.80
                  REMOTE: 192.168.100.39
                  MAC:    000A8501858E
   004  Enabled   Serial Port 1 [S1]
 ----------------------------
 Debugger: Disabled 
 ----------------------------
  1 - Enable/disable tests
  2 - Enable/disable boot devices
  3 - Change IP addresses
  4 - Ping test
  5 - Toggle ROM monitor debugger
  6 - Toggle automatic menu
  7 - Display configuration
  8 - Save changes to configuration
  9 - Set baud rate for s1 boot
  A - Enable/disable I cache (Enabled )
  B - Enable/disable D cache (Enabled )
  F - FLASH image update
  M - Memory Test
  0 - Exit menu and continue
->0
Booting from [ENET] Ethernet     ...
Sending bootp request ...
Loading file "/netbsd.img" ...
Sending tftp boot request ...
Transfer Complete ...
Loaded successfully ...
Entry point at 0x25000 ...
+4000000,
00025000-04000000 -> 00344000-04000000 = 3cbc000
Loading pages
Done
Board config data:
  usr_config_ver = 1.4
  rom_sw_ver = 1.2
  mem_size = 67108864
  mac_address_local = 00:0a:85:01:85:8e
  mac_address_pci = 00:0a:85:01:05:8e
  processor_speed = 266666666
  plb_speed = 133333333
  pci_speed = 33333333
Loaded initial symtab at 0x297da0, strtab at 0x2b766c, # entries 8017
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.
NetBSD 1.6ZF (OPENBLOCKS266) #1: Sat Nov 22 16:29:52 UTC 2003
        tokuda@cube:/usr/export/s/20031121/src/sys/arch/evbppc/compile/OPENBLOCKS266
Model: OpenBlockS266 IBM PowerPC 405GPr Board
total memory = 65536 KB
avail memory = 58288 KB
using 211 buffers containing 3376 KB of memory
plb0 (root)
cpu0 at plb0: 266MHz 405GPr (Revision 9.81)
Instruction cache size 16384 line size 32
Data cache size 16384 line size 32
PVR: owner 509 core family 1 cache 2 version 5 asic 11
ecc0 at plb0 irq 16: ECC controller
opb0 at plb0
com0 at opb0 addr 0xef600300 irq 0: ns16550a, working fifo
com0: console
com1 at opb0 addr 0xef600400 irq 1: ns16550a, working fifo
emac0 at opb0 addr 0xef600800 irq 9: 405GP EMAC
emac0: interrupting at irqs 9 .. 15
emac0: Ethernet address 00:0a:85:01:85:8e
lxtphy0 at emac0 phy 0: LXT971 10/100 media interface, rev. 2
lxtphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
gpio at opb0 addr 0xef600700 not configured
gpiic0 at opb0 addr 0xef600500 irq 2: On-Chip IIC controller
iic0 at gpiic0: I2C bus
xrtc0 at iic0 addr 0x6f: Xicor X1226 Real-time Clock/NVRAM
wdog0 at opb0: 4 second period
pchb0 at plb0
pchb0: IBM PPC 405GP PCI Bridge (rev. 0x21)
pci0 at pchb0
pci0: i/o space, memory space enabled
IBM PPC 405GP PCI Bridge (host bridge, revision 0x21) at pci0 dev 0 function 0 not configured
hptide0 at pci0 dev 3 function 0
hptide0: Triones/Highpoint HPT371 IDE Controller
hptide0: bus-master DMA support present
hptide0: primary channel wired to native-PCI mode
hptide0: using irq 30 for native-PCI interrupt
atabus0 at hptide0 channel 0
hptide0: secondary channel wired to native-PCI mode
atabus1 at hptide0 channel 1
tlp0 at pci0 dev 4 function 0: Davicom DM9102A Ethernet, pass 4.0
tlp0: broken MicroWire interface detected; setting SROM size to 1Kb
tlp0: interrupting at irq 31
tlp0: Ethernet address 00:0a:85:01:05:8e
ukphy0 at tlp0 phy 1: Generic IEEE 802.3u media interface
ukphy0: OUI 0x000676, model 0x0004, rev. 1
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pbus at plb0 not configured
biomask 1c02 netmask 1c03 ttymask 1c03
Setting PIT to 266666666/100 = 2666666
wd0 at atabus1 drive 0: 
wd0: drive supports 16-sector PIO transfers, LBA addressing
wd0: 19077 MB, 38760 cyl, 16 head, 63 sec, 512 bytes/sect x 39070080 sectors
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 5 (Ultra/100)
wd0(hptide0:1:0): using PIO mode 4, Ultra-DMA mode 5 (Ultra/100) (using DMA data transfers)
root device: emac0
dump device: 
file system (default generic): nfs
root on emac0
nfs_boot: trying DHCP/BOOTP
nfs_boot: BOOTP next-server: 192.168.100.39
nfs_boot: my_name=obs266
nfs_boot: my_addr=192.168.100.80
nfs_boot: my_mask=255.255.255.0
root on cube:/usr/obs266
root time: 0x3fbf9267
inittodr: Clock has lost 12346 day(s) - CHECK AND RESET THE DATE.
init path (default /sbin/init): 
init: copying out path `/sbin/init' 11
Mon Feb  2 02:02:17 UTC 1970
Starting file system checks:
mount: /: unknown special file or file system.
Setting tty flags.
Setting sysctl variables:
Starting network.
Hostname: obs266.home.tokuda.net
IPv6 mode: host
Configuring network interfaces:.
add net default: gateway 192.168.100.1
Building databases...
Starting syslogd.
Checking for core dump...
savecore: can't find device 1651/708
Feb  2 02:03:09 obs266 savecore: can't find device 1651/708
Mounting all filesystems...
Clearing /tmp.
Checking quotas: done.
Setting securelevel: kern.securelevel: 0 -> 1
/etc/rc: WARNING: No swap space configured!
Starting virecover.
Starting local daemons:.
Updating motd.
Starting sshd.
Starting inetd.
Starting cron.
Mon Feb  2 02:03:47 UTC 1970
NetBSD/evbppc (obs266.home.tokuda.net) (console)
login: root
Last login: Mon Feb  2 02:03:37 1970 on console
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003
Feb  2 02:04:15 obs266 login: ROOT LOGIN (root) ON console
        The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1980, 1983, 1986, 1988, 1990, 1991, 1993, 1994
        The Regents of the University of California.  All rights reserved.
NetBSD 1.6ZF (OPENBLOCKS266) #1: Sat Nov 22 16:29:52 UTC 2003
Welcome to NetBSD!
Feb  2 02:04:15 obs266 login: ROOT LOGIN (root) ON console
Terminal type is vt100.                                                 
We recommend creating a non-root account and using su(1) for root access.
obs266# disklabel wd0
wd0: no disk label
# /dev/rwd0c:
type: ESDI
disk: TOSHIBA MK2023GA
label: fictitious
flags:
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 16
sectors/cylinder: 1008
cylinders: 38760
total sectors: 39070080
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0           # microseconds
track-to-track seek: 0  # microseconds
drivedata: 0 
3 partitions:
#        size    offset     fstype [fsize bsize cpg/sgs]
 c:  39070080         0     unused      0     0        # (Cyl.      0 -  38759)
disklabel: boot block size 0
disklabel: super block size 0
obs266# Feb  2 02:04:21 obs266 /netbsd: wd0: no disk label
obs266# 
obs266# disklabel -i -I wd0
wd0: no disk label
Feb  2 02:05:09 obs266 /netbsd: wd0: no disk label
partition> P
3 partitions:
#        size    offset     fstype [fsize bsize cpg/sgs]
 c:  39070080         0     unused      0     0        # (Cyl.      0 -  38759)
partition> a
Filesystem type [?] [unused]: 4.2BSD
Start offset [0c, 0s, 0M]: 0
Partition size ('$' for all remaining) [0c, 0s, 0M]: 128M
 a:    262144         0     4.2BSD      0     0     0  # (Cyl.      0 -    260*)
partition> b
Filesystem type [?] [unused]: swap
Start offset [0c, 0s, 0M]: 262144
Partition size ('$' for all remaining) [0c, 0s, 0M]: 128M
 b:    262144    262144       swap                     # (Cyl.    260*-    520*)
partition> d
Filesystem type [?] [unused]: 4.2BSD
Start offset [0c, 0s, 0M]: 524288
Partition size ('$' for all remaining) [0c, 0s, 0M]: 512M
 d:   1048576    524288     4.2BSD      0     0     0  # (Cyl.    520*-   1560*)
partition> e
Filesystem type [?] [unused]: 
Start offset [0c, 0s, 0M]: 
Partition size ('$' for all remaining) [0c, 0s, 0M]: 
partition> e
Filesystem type [?] [unused]: 4.2BSD
Start offset [0c, 0s, 0M]: 1572864
Partition size ('$' for all remaining) [0c, 0s, 0M]: 1000M
 e:   2048000   1572864     4.2BSD      0     0     0  # (Cyl.   1560*-   3592*)
partition> f
Filesystem type [?] [unused]: 4.2BSD
Start offset [0c, 0s, 0M]: 3620864
Partition size ('$' for all remaining) [0c, 0s, 0M]: $
 f:  35449216   3620864     4.2BSD      0     0     0  # (Cyl.   3592*-  38759)
partition> P
6 partitions:
#        size    offset     fstype [fsize bsize cpg/sgs]
 a:    262144         0     4.2BSD      0     0     0  # (Cyl.      0 -    260*)
 b:    262144    262144       swap                     # (Cyl.    260*-    520*)
 c:  39070080         0     unused      0     0        # (Cyl.      0 -  38759)
 d:   1048576    524288     4.2BSD      0     0     0  # (Cyl.    520*-   1560*)
 e:   2048000   1572864     4.2BSD      0     0     0  # (Cyl.   1560*-   3592*)
 f:  35449216   3620864     4.2BSD      0     0     0  # (Cyl.   3592*-  38759)
partition> W
Label disk [n]? y
Label written
partition> Q
obs266#
obs266# newfs /dev/rwd0a
/dev/rwd0a: 16384.0MB (262144 sectors) block size 8192, fragment size 1024
        using 4 cylinder groups of 7168.00MB, 4096 blks, 7936 inodes.
wd0: transfer error, downgrading to Ultra-DMA mode 2
wd0(hptide0:1:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA data transfers)
wd0a: error writing fsbn 32 of 32-95 (wd0 bn 32; cn 0 tn 0 sn 32), retrying
wd0: (aborted command, interface CRC error)
Feb  2 02:15:47 obs266 /netbsd: wd0: transfer error, downgrading to Ultra-DMA mode 2
Feb  2 02:15:48 obs266 /netbsd: wd0(hptide0:1:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA data transfers)
Feb  2 02:15:48 obs266 /netbsd: wd0a: error writingwd0: soft error (corrected)
 fsbn 32 of 32-95 (wd0 bn 32; cn 0 tn 0 sn 32), retrying
Feb  2 02:15:48 obs266 /netbsd: wd0: (aborted command, interface CRC error)
Feb  2 02:15:48 obs266 /netbsd: wd0: soft error (corrected)
super-block backups (for fsck -b #) at:
     32,  65568, 131104, 196640,
obs266#
obs266# newfs /dev/rwd0d
/dev/rwd0d: 81920.0MB (1048576 sectors) block size 8192, fragment size 1024
        using 12 cylinder groups of 8704.75MB, 5462 blks, 10560 inodes.
super-block backups (for fsck -b #) at:
     32,  87424, 174816, 262208, 349600, 436992, 524384, 611776, 699168, 786560,
 873952, 961344,
obs266#
obs266# newfs /dev/rwd0e
/dev/rwd0e: 188928.0MB (2048000 sectors) block size 16384, fragment size 2048
        using 6 cylinder groups of 25621.75MB, 10667 blks, 20992 inodes.
super-block backups (for fsck -b #) at:
      32,  341376,  682720, 1024064, 1365408, 1706752,
obs266#
obs266# newfs /dev/rwd0f
/dev/rwd0f: 3744032.0MB (35449216 sectors) block size 16384, fragment size 2048
        using 94 cylinder groups of 27019.25MB, 11785 blks, 23168 inodes.
super-block backups (for fsck -b #) at:
       32,   377152,   754272,  1131392,  1508512,  1885632,  2262752,  2639872,
  3016992,  3394112,  3771232,  4148352,  4525472,  4902592,  5279712,  5656832,
  6033952,  6411072,  6788192,  7165312,  7542432,  7919552,  8296672,  8673792,
  9050912,  9428032,  9805152, 10182272, 10559392, 10936512, 11313632, 11690752,
 12067872, 12444992, 12822112, 13199232, 13576352, 13953472, 14330592, 14707712,
 15084832, 15461952, 15839072, 16216192, 16593312, 16970432, 17347552, 17724672,
 18101792, 18478912, 18856032, 19233152, 19610272, 19987392, 20364512, 20741632,
 21118752, 21495872, 21872992, 22250112, 22627232, 23004352, 23381472, 23758592,
 24135712, 24512832, 24889952, 25267072, 25644192, 26021312, 26398432, 26775552,
 27152672, 27529792, 27906912, 28284032, 28661152, 29038272, 29415392, 29792512,
 30169632, 30546752, 30923872, 31300992, 31678112, 32055232, 32432352, 32809472,
 33186592, 33563712, 33940832, 34317952, 34695072, 35072192,
obs266#
obs266# cd /
obs266# mkdir /root
mkdir: /root: File exists
obs266# mkdir /hdd1
obs266# cd hdd1
obs266# mkdir var usr export
obs266# ls
export usr    var
obs266# mount -t ffs /dev/wd0a /hdd1
obs266# mount -t ffs /dev/wd0d /hdd1/var
mount_ffs: /dev/wd0d on /hdd1/var: No such file or directory
obs266# mkdir /hdd1/var
obs266# mkdir /hdd1/export
obs266# mount -t ffs /dev/wd0d /hdd1/var
obs266# mount -t ffs /dev/wd0e /hdd1/usr
mount_ffs: /dev/wd0e on /hdd1/usr: No such file or directory
obs266# mkdir /hdd1/usr
obs266# mount -t ffs /dev/wd0e /hdd1/usr
obs266# pwd
/hdd1
obs266# mkdir sets.20031121
obs266# cd sets.20031121
obs266# ftp cube
ftp: No address associated with hostname
ftp> quit
obs266# ftp 192.168.100.39
Connected to 192.168.100.39.
220 cube.home.tokuda.net FTP server (NetBSD-ftpd 20030630) ready.
Name (192.168.100.39:root): tokuda
331 Password required for tokuda.
Password:
230-
    NetBSD 1.6ZC (GENERIC) #0: Thu Sep 18 02:33:39 UTC 2003
    
    Welcome to NetBSD!
    
230 User tokuda logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> cd /export/r/20031121/evbppc/evbpps/binary/sets
550 /export/r/20031121/evbppc/evbpps/binary/sets: No such file or directory.
ftp> cd /export/r/20031121/evbppc/evbppc/binary/sets
250 CWD command successful.
ftp> bi
200 Type set to I.
ftp> prompt
Interactive mode off.
ftp> mget *.tgzobs266# cd /
obs266# mkdir /root
mkdir: /root: File exists
obs266# mkdir /hdd1
obs266# cd hdd1
obs266# mkdir var usr export
obs266# ls
export usr    var
obs266# mount -t ffs /dev/wd0a /hdd1
obs266# mount -t ffs /dev/wd0d /hdd1/var
mount_ffs: /dev/wd0d on /hdd1/var: No such file or directory
obs266# mkdir /hdd1/var
obs266# mkdir /hdd1/export
obs266# mount -t ffs /dev/wd0d /hdd1/var
obs266# mount -t ffs /dev/wd0e /hdd1/usr
mount_ffs: /dev/wd0e on /hdd1/usr: No such file or directory
obs266# mkdir /hdd1/usr
obs266# mount -t ffs /dev/wd0e /hdd1/usr
obs266# pwd
/hdd1
obs266# mkdir sets.20031121
obs266# cd sets.20031121
obs266# ftp cube
ftp: No address associated with hostname
ftp> quit
obs266# ftp 192.168.100.39
Connected to 192.168.100.39.
220 cube.home.tokuda.net FTP server (NetBSD-ftpd 20030630) ready.
Name (192.168.100.39:root): tokuda
331 Password required for tokuda.
Password:
230-
    NetBSD 1.6ZC (GENERIC) #0: Thu Sep 18 02:33:39 UTC 2003
    
    Welcome to NetBSD!
    
230 User tokuda logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> cd /export/r/20031121/evbppc/evbpps/binary/sets
550 /export/r/20031121/evbppc/evbpps/binary/sets: No such file or directory.
ftp> cd /export/r/20031121/evbppc/evbppc/binary/sets
250 CWD command successful.
ftp> bi
200 Type set to I.
ftp> prompt
Interactive mode off.
ftp> mget *.tgz
local: base.tgz remote: base.tgz
229 Entering Extended Passive Mode (|||64498|)
150 Opening BINARY mode data connection for 'base.tgz' (17074386 bytes).
100% |*************************************| 16674 KB    4.57 MB/s    00:00 ETA
226 Transfer complete.
17074386 bytes received in 00:03 (4.57 MB/s)
local: comp.tgz remote: comp.tgz
229 Entering Extended Passive Mode (|||64497|)
150 Opening BINARY mode data connection for 'comp.tgz' (23511802 bytes).
100% |*************************************| 22960 KB    4.82 MB/s    00:00 ETA
226 Transfer complete.
23511802 bytes received in 00:04 (4.82 MB/s)
local: etc.tgz remote: etc.tgz
229 Entering Extended Passive Mode (|||64496|)
150 Opening BINARY mode data connection for 'etc.tgz' (153136 bytes).
100% |*************************************|   149 KB    3.29 MB/s    00:00 ETA
226 Transfer complete.
153136 bytes received in 00:00 (772.74 KB/s)
local: games.tgz remote: games.tgz
229 Entering Extended Passive Mode (|||64495|)
150 Opening BINARY mode data connection for 'games.tgz' (3014584 bytes).
100% |*************************************|  2943 KB    4.61 MB/s    00:00 ETA
226 Transfer complete.
3014584 bytes received in 00:00 (4.59 MB/s)
local: kern-WALNUT.tgz remote: kern-WALNUT.tgz
229 Entering Extended Passive Mode (|||64494|)
150 Opening BINARY mode data connection for 'kern-WALNUT.tgz' (3865904 bytes).
100% |*************************************|  3775 KB    4.61 MB/s    00:00 ETA
226 Transfer complete.
3865904 bytes received in 00:00 (4.57 MB/s)
local: man.tgz remote: man.tgz
229 Entering Extended Passive Mode (|||64493|)
150 Opening BINARY mode data connection for 'man.tgz' (7260503 bytes).
100% |*************************************|  7090 KB    4.68 MB/s    00:00 ETA
226 Transfer complete.
7260503 bytes received in 00:01 (4.66 MB/s)
local: misc.tgz remote: misc.tgz
229 Entering Extended Passive Mode (|||64492|)
150 Opening BINARY mode data connection for 'misc.tgz' (2897715 bytes).
100% |*************************************|  2829 KB    4.76 MB/s    00:00 ETA
226 Transfer complete.
2897715 bytes received in 00:00 (4.73 MB/s)
local: text.tgz remote: text.tgz
229 Entering Extended Passive Mode (|||64491|)
150 Opening BINARY mode data connection for 'text.tgz' (2233272 bytes).
100% |*************************************|  2180 KB    4.75 MB/s    00:00 ETA
226 Transfer complete.
2233272 bytes received in 00:00 (4.70 MB/s)
ftp> quit
221-
    Data traffic for this session was 60011302 bytes in 8 files.
    Total traffic for this session was 60014336 bytes in 9 transfers.
221 Thank you for using the FTP service on cube.home.tokuda.net.
obs266#
obs266# ls
base.tgz        etc.tgz         kern-WALNUT.tgz misc.tgz
comp.tgz        games.tgz       man.tgz         text.tgz
obs266# pwd
/hdd1/sets.20031121
obs266# cd ..
obs266# foreach i (^C
obs266# PWD
PWD: Command not found.
obs266# pwd
/hdd1
obs266# foreach i ( /hdd1/sets.20031121/*.tgz)
? pax -rzpe -f $i 
? end
obs266# ls
.cshrc          dev             libexec         rescue          stand
.profile        etc             mnt             root            tmp
altroot         export          netbsd          sbin            usr
bin             lib             netbsd.img      sets.20031121   var
obs266# cd dev
obs266# pwd
/hdd1/dev
obs266# ./MAKEDEV all
obs266# cd /hdd1/etc
obs266# mv rc.conf rc.conf.orig
obs266# sed s/NO/YES/ rc.conf.orig > rc.conf
obs266# echo hostname=\"obs266\" >> rc.conf
obs266# echo ifconfig_emac0=\"inet 192.168.100.80 netmask 255.255.255.0\" >> rc.conf
obs266# echo defaultrouter=\"192.168.100.1\" >> rc.conf
obs266# echo sshd=YES >> rc.conf
obs266# echo "/dev/wd0a / ffs rw 1 1" > fstab
obs266# echo "/dev/wd0b none swap sw 0 0" >> fstab
obs266# echo "/dev/wd0d /var ffs rw 1 2" >> fstab
obs266# echo "/dev/wd0e /usr/ffs rw 1 2" >> fstab
obs266# cat fstab
/dev/wd0a / ffs rw 1 1
/dev/wd0b none swap sw 0 0
/dev/wd0d /var ffs rw 1 2
/dev/wd0e /usr/ffs rw 1 2
obs266# sync;sync;sync
obs266# rebootobs266# cd /hdd1/etc
obs266# mv rc.conf rc.conf.orig
obs266# sed s/NO/YES/ rc.conf.orig > rc.conf
obs266# echo hostname=\"obs266\" >> rc.conf
obs266# echo ifconfig_emac0=\"inet 192.168.100.80 netmask 255.255.255.0\" >> rc.conf
obs266# echo defaultrouter=\"192.168.100.1\" >> rc.conf
obs266# echo sshd=YES >> rc.conf
obs266# echo "/dev/wd0a / ffs rw 1 1" > fstab
obs266# echo "/dev/wd0b none swap sw 0 0" >> fstab
obs266# echo "/dev/wd0d /var ffs rw 1 2" >> fstab
obs266# echo "/dev/wd0e /usr/ffs rw 1 2" >> fstab
obs266# cat fstab
/dev/wd0a / ffs rw 1 1
/dev/wd0b none swap sw 0 0
/dev/wd0d /var ffs rw 1 2
/dev/wd0e /usr/ffs rw 1 2
obs266# sync;sync;sync
obs266# reboot
Feb  2 02:57:43 obs266 reboot: rebooted by root
Feb  2 02:57:43 obs266 reboot: rebooted by root
Feb  2 02:57:43 obs266 syslogd: Exiting on signal 15
Feb  2 02:57:43 obs266 syslogd: Exiting on signal 15
syncing disks... done
unmounting /hdd1/usr (/dev/wd0e)...
unmounting /hdd1/var (/dev/wd0d)...
unmounting /hdd1 (/dev/wd0a)...
unmounting / (cube:/usr/obs266)...
xrtc0: xrtc_clock_write: failed to write-unlock status register(RWEL=1)
resettodr: failed to set time
rebooting
405GPr 1.2 ROM Monitor (5/25/02)
 --------------------- System Info ----------------------
 Processor         = 405GPr (New mode),   PVR: 50910951
 CPU speed         = 266 MHz
 PLB speed         = 133 MHz
 OPB speed         = 66 MHz
 EBC speed         = 66 MHz
 PCI Bus speed     = 33 MHz (Async)
 VCO speed         = 800 MHz
 Feedback Clock    = CPU
 Amount of SDRAM   = 64 MBytes 
 Internal PCI arbiter enabled
 --------------------------------------------------------
 --- Device Configuration ---
 Power-On Test Devices:
   000  Enabled   System Memory [RAM]
   002  Enabled   Ethernet      [ENET]
   003  Enabled   PCI Ethernet  [PCIENET]
 ----------------------------
 Boot Sources:
   001  Disabled  System FLASH  [FLASH]
   002  Enabled   Ethernet      [ENET]
                  LOCAL:  192.168.100.80
                  REMOTE: 192.168.100.39
                  MAC:    000A8501858E
   004  Enabled   Serial Port 1 [S1]
 ----------------------------
 Debugger: Disabled 
 ----------------------------
  1 - Enable/disable tests
  2 - Enable/disable boot devices
  3 - Change IP addresses
  4 - Ping test
  5 - Toggle ROM monitor debugger
  6 - Toggle automatic menu
  7 - Display configuration
  8 - Save changes to configuration
  9 - Set baud rate for s1 boot
  A - Enable/disable I cache (Enabled )
  B - Enable/disable D cache (Enabled )
  F - FLASH image update
  M - Memory Test
  0 - Exit menu and continue
->0
Booting from [ENET] Ethernet     ...
Sending bootp request ...
Loading file "/netbsd.img" ...
Sending tftp boot request ...
Transfer Complete ...
Loaded successfully ...
Entry point at 0x25000 ...
+4000000,
00025000-04000000 -> 00344000-04000000 = 3cbc000
Loading pages
Done
Board config data:
  usr_config_ver = 1.4
  rom_sw_ver = 1.2
  mem_size = 67108864
  mac_address_local = 00:0a:85:01:85:8e
  mac_address_pci = 00:0a:85:01:05:8e
  processor_speed = 266666666
  plb_speed = 133333333
  pci_speed = 33333333
Loaded initial symtab at 0x297da0, strtab at 0x2b766c, # entries 8017
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.
NetBSD 1.6ZF (OPENBLOCKS266) #1: Sat Nov 22 16:29:52 UTC 2003
        tokuda@cube:/usr/export/s/20031121/src/sys/arch/evbppc/compile/OPENBLOCKS266
Model: OpenBlockS266 IBM PowerPC 405GPr Board
total memory = 65536 KB
avail memory = 58288 KB
using 211 buffers containing 3376 KB of memory
plb0 (root)
cpu0 at plb0: 266MHz 405GPr (Revision 9.81)
Instruction cache size 16384 line size 32
Data cache size 16384 line size 32
PVR: owner 509 core family 1 cache 2 version 5 asic 11
ecc0 at plb0 irq 16: ECC controller
opb0 at plb0
com0 at opb0 addr 0xef600300 irq 0: ns16550a, working fifo
com0: console
com1 at opb0 addr 0xef600400 irq 1: ns16550a, working fifo
emac0 at opb0 addr 0xef600800 irq 9: 405GP EMAC
emac0: interrupting at irqs 9 .. 15
emac0: Ethernet address 00:0a:85:01:85:8e
lxtphy0 at emac0 phy 0: LXT971 10/100 media interface, rev. 2
lxtphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
gpio at opb0 addr 0xef600700 not configured
gpiic0 at opb0 addr 0xef600500 irq 2: On-Chip IIC controller
iic0 at gpiic0: I2C bus
xrtc0 at iic0 addr 0x6f: Xicor X1226 Real-time Clock/NVRAM
wdog0 at opb0: 4 second period
pchb0 at plb0
pchb0: IBM PPC 405GP PCI Bridge (rev. 0x21)
pci0 at pchb0
pci0: i/o space, memory space enabled
IBM PPC 405GP PCI Bridge (host bridge, revision 0x21) at pci0 dev 0 function 0 not configured
hptide0 at pci0 dev 3 function 0
hptide0: Triones/Highpoint HPT371 IDE Controller
hptide0: bus-master DMA support present
hptide0: primary channel wired to native-PCI mode
hptide0: using irq 30 for native-PCI interrupt
atabus0 at hptide0 channel 0
hptide0: secondary channel wired to native-PCI mode
atabus1 at hptide0 channel 1
tlp0 at pci0 dev 4 function 0: Davicom DM9102A Ethernet, pass 4.0
tlp0: broken MicroWire interface detected; setting SROM size to 1Kb
tlp0: interrupting at irq 31
tlp0: Ethernet address 00:0a:85:01:05:8e
ukphy0 at tlp0 phy 1: Generic IEEE 802.3u media interface
ukphy0: OUI 0x000676, model 0x0004, rev. 1
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pbus at plb0 not configured
biomask 1c02 netmask 1c03 ttymask 1c03
Setting PIT to 266666666/100 = 2666666
wd0 at atabus1 drive 0: 
wd0: drive supports 16-sector PIO transfers, LBA addressing
wd0: 19077 MB, 38760 cyl, 16 head, 63 sec, 512 bytes/sect x 39070080 sectors
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 5 (Ultra/100)
wd0(hptide0:1:0): using PIO mode 4, Ultra-DMA mode 5 (Ultra/100) (using DMA data transfers)
root device: wd0a
dump device (default wd0b): 
file system (default generic): ffs
root on wd0a dumps on wd0b
init path (default /sbin/init): 
init: copying out path `/sbin/init' 11
Mon Feb  2 02:02:08 GMT 1970
swapctl: adding /dev/wd0b as swap device at priority 0
swapctl: /etc/fstab, 4: Missing fields
Starting file system checks:
/dev/rwd0a: file system is clean; not checking
fsck: /etc/fstab, 4: Missing fields
fsck: /etc/fstab, 4: Missing fields
/dev/rwd0d: file system is clean; not checking
Setting tty flags.
Setting sysctl variables:
Starting network.
Hostname: obs266
IPv6 mode: host
Configuring network interfaces: emac0.
Adding interface aliases:
wd0: transfer error, downgrading to Ultra-DMA mode 2
wd0(hptide0:1:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA data transfers)
wd0a: error writing fsbn 65616 of 65616-65631 (wd0 bn 65616; cn 65 tn 1 sn 33), retrying
wd0: (aborted command, interface CRC error)
wd0: soft error (corrected)
Building databases...
dev_mkdb: not found
install: not found
install: not found
Checking for core dump...
savecore: can't find device 602/9728
Mounting all filesystems...
mount: /etc/fstab, 4: Missing fields
Clearing /tmp.
find: not found
Checking quotas:eval: /usr/sbin/quotacheck: not found
 done.
eval: /usr/sbin/quotaon: not found
Setting securelevel: kern.securelevel: 0 -> 1
swapctl: /etc/fstab, 4: Missing fields
grep: not found
Starting local daemons:.
Updating motd.
sed: not found
cmp: not found
Mon Feb  2 02:03:09 GMT 1970
Feb  2 02:03:10 init: can't exec getty '/usr/libexec/getty' for port /dev/console: No such file or directory
Feb  2 02:03:40 init: can't exec getty '/usr/libexec/getty' for port /dev/console: No such file or directory
Feb  2 02:04:10 init: can't exec getty '/usr/libexec/getty' for port /dev/console: No such file or directory
Feb  2 02:04:40 init: can't exec getty '/usr/libexec/getty' for port /dev/console: No such file or directory
Feb  2 02:05:10 init: can't exec getty '/usr/libexec/getty' for port /dev/console: No such file or directory
Feb  2 02:05:40 init: can't exec getty '/usr/libexec/getty' for port /dev/console: No such file or directory


[View Log(0)] [Trackback]
Name: Comment:

2003/11/23 (日)

1年と278日目

昨日の暴れまくりでよく寝た。


[View Log(0)] [Trackback]
Name: Comment:

cyrus

cyrusで毎回ハマっているんですが。

sasl.dbのパーミッションとか。

saslauthd, cyrusの再起動しわすれとか。

cyradmがやっぱりうまく起動できず、authを順番に試すとか (digest-md5が正解だった)。

bobby# cyradm --user cyrus --auth digest-md5 localhost


[View Log(0)] [Trackback]
Name: Comment:

2003/11/24 (月)

1年と279日目

連休最終日。

アキバにおでかけ。

寒かったけど元気に歩き回ったり。

家に帰ってきて炊飯器の蒸気でやけど。赤くなっている。


[View Log(0)] [Trackback]
Name: Comment:

アキバ

ぷらっとでOpenBlockS266のPCMCIAオプション買ったり。

10% OFFのセールやってたのでラッキー。

アソビットシティでプラレール買ったり。

  • OpenBlockS266用 PCMCIAアダプタBOX, ぷらっとホーム, 11,520円

プラレール

  • 700系新幹線S-1, 1,280円
  • J-21 エレクトロ踏切, 2,000円
  • J-15, ミニ橋, 520円
  • R-01, 直線レール, 240円
  • R-03, 曲線レール, 240円
  • R-13, 単線/複線ポイントレール, 280円


[View Log(0)] [Trackback]
Name: Comment:

NetBSD/evbppc

OBS266のPCMCIAボックスを動かす。

パッチを当ててkernelを作ってごにょごにょ。

おぉ、ちゃんと動くぞ。

Air-H", 無線LANが動くのは大きいな。

手元にあったカードをかたっぱしから試して、動作確認。

結果をsoumのNetBSDなMLで報告。

で、そんなこんなですごい時間に。


[View Log(0)] [Trackback]
Name: Comment:

2003/11/25 (火)

1年と280日目

週のはじめに雨が降るのはいやがらせですか?

ていうか、起きられませんでしたよ。

めやにが大量に出るので明日は病院かな。


[View Log(0)] [Trackback]
Name: Comment:

2003/11/26 (水)

1年と281日目

めやにがおさらまらず、病院へ。

とりあえず、心配ないらしい。目薬をもらう。


[View Log(0)] [Trackback]
Name: Comment:

風邪

ひさしぶりに風邪らしい風邪をひいたらしい。

まったく人として使いものにならない状態となり、寝る。


[View Log(0)] [Trackback]
Name: Comment:

2003/11/27 (木)

1年と282日目

めやにはおさまってきた。よかったよかった。


[View Log(0)] [Trackback]
Name: Comment:

風邪

よくならず。

本日もおとなしく寝る。


[View Log(0)] [Trackback]
Name: Comment:

2003/11/28 (金)

1年と283日目

めやにはほぼ収束かな。


[View Log(0)] [Trackback]
Name: Comment:

風邪

すこし回復。風邪薬はそれなりに飲んでいる。


[View Log(0)] [Trackback]
Name: Comment:

2003/11/29 (土)

1年と284日目

天気が悪いし寒いからベランダに出る程度。

まぁ、体力温存だな。


[View Log(0)] [Trackback]
Name: Comment:

風邪

だいぶ良くなった。たまに頭痛がするけれど。


[View Log(0)] [Trackback]
Name: Comment:

2003/11/30 (日)

1年と284日目

元気だ。

みかんを良く食べる。

昼前に荷物が届く。写真をすぐに送り返した。


[View Log(0)] [Trackback]
Name: Comment:

日記

激動の一週間分を補間。


[View Log(0)] [Trackback]
Name: Comment:

いろいろ

手元のdaily buildスクリプトを見直して、整理する。

x1226.cを覗いてみたり。

雑多な作業をいろいろと。


[View Log(0)] [Trackback]
Name: Comment:

quota

quotaを越えてしばらくほったらかしにしていたらしく、メールなどがいろいろと失われたらしい。

CGIもまともに動かず、ファイルが消えたりとひどいありさま。

100Mbytes程度の容量では足りないよなぁ。


[View Log(0)] [Trackback]
Name: Comment:

NetBSD/evbppcとcvsync

kernelとuserlandを20031127にする。

もう少し新しくすればHPT371が入っているのだけど。

RTCはいろいろ見てみたけど良くわからず。IRCで進捗があったような、なかったような。

cvsync-0.24.13をOBS266に入れてみる。

pthreadでこけているのかな?

obs266# cvsync
Connecting to cvsync.allbsd.org port 7777
host 3ffe:501:1888:1::35 port 7777: No route to host
Connected to 133.31.130.35 port 7777
Running...
Dec  1 03:19:04 obs266 /netbsd: pid 349 (cvsync), uid 0: exited on signal 11 (core dumped)
Segmentation fault (core dumped)
obs266# gdb cvsync cvsync.core
GNU gdb 5.3nb1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "powerpc--netbsd"...(no debugging symbols found)...
Core was generated by `cvsync'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/libexec/ld.elf_so...(no debugging symbols found)...
done.
Loaded symbols for /usr/libexec/ld.elf_so
Reading symbols from /usr/lib/libz.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libz.so.0
Reading symbols from /usr/lib/libpthread.so.0...(no debugging symbols found)...
done.
Loaded symbols for /usr/lib/libpthread.so.0
Reading symbols from /usr/lib/libc.so.12...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libc.so.12
#0  0x41896770 in ?? () from /usr/lib/libpthread.so.0
(gdb)


[View Log(0)] [Trackback]
Name: Comment:

NetBSD/mpc860

mpc860-031129.tar.gzがでてた。

今ごろ気づいてしまったよ。


[View Log(0)] [Trackback]
Name: Comment:


メールはこちらへ...[BSD小僧 (tokuda @(at) tokuda .(dot) net)]

この日記は、GNSを使用して作成されています。